Обновление JoomGallery до последней версии

Мы всегда хотели предоставить пользователям более старых версий возможность обновления галереи, если новая версия галереи была доступна. С Updatezip для PonyGallery можно обновить любую старую версию на 2.5.1.

С публикацией JoomGallery мы также предоставляем Менеджер миграции, чтобы перенести изображения с PonyGallery ML в JoomGallery. Кроме того, для JoomGallery 1.0.0 есть Updatezip для актуализации старых версий.

Тоже самое мы также предлагаем для JoomGallery 1.5.5. Это будет не обновление вручную, что приводит отчасти к некоторым проблемам. Вы можете использовать функцию автоматического обновления, чтобы получать обновления, или, если это невозможно, скачать Zip файл загрузки и установить их через менеджер расширений Joomla!. Не удаляя при этом существующий компонент галереи.

Процесс обновления будет распознавать старые версии компонента галереи (начиная с версии 1.0) и модифицирует их до последних версий. Изображения и категории не удаляются.

Как сделать переход от JoomGallery 1.0.0 к новой JoomGallery 1.5.5? В этой версии есть изменения в структуре базы данных, поэтому экспорт/импорт базы данных и простая замена файлов больше невозможно. В этом FAQ мы будем это объяснять на основе примера чуть ниже.

Примеры будут показаны на примере JoomGallery 1.5.5 и Joomla 1.5.x. По соображениям безопасности вы всегда должны использовать актуальную версию Joomla! 1.5.x. Если необходимо сделать обновление Joomla до последней версии, то лучше сделать это сейчас перед обновлением JoomGallery.

Пожалуйста, сделайте обновление базы данных и файлов в следующих шагах:

  • Перед миграцией в JoomGallery Вам нужно скопировать все данные, потому что данные PonyGallery будут удалены, и таблицы базы данных тоже.
  • Сделайте резервную копию всех файлов по FTP.

Миграция от PonyGallery ML 2.5.1 до JoomGallery 1.0 в Joomla 1.0

Обновление JoomGallery до последней версии

Внимательно следуйте инструкции, чтобы избежать ошибок в процессе обновления:

  • При необходимости обновите PonyGallery ML с Updatezip до версии 2.5.1
  • Параллельно установите JoomGallery 1.0.0 в Joomla 1.0.x
  • Начните миграцию из PonyGallery в JoomGallery с помощью Migration Manager
  • Вручную перекиньте таблицы баз данных в PHPMyAdmin из одного компонента в другой и тоже самое сделайте с файлами (изображениями)
  • Если существуют различия между префиксами таблиц баз данных, то нужно их вручную заменить на компьютере с помощью текстового редактора
  • Установить JoomGallery 1.0.0 в Joomla 1.5 с активированным режимом Legacy Plug-in
  • Теперь вручную импортировать базы данных в JoomGallery 1.0.0 на Joomla 1.5
  • После этого можно обновить версию JoomGallery до последней актуальной версии (1.5.x и выше) в Joomla 1.5

Вот и вся инструкция. Сложного ничего нет. Главное не забывать делать заранее резервные копии файлов сайта и базы данных, чтобы можно было в случае неудачи вернуть всё на место

Свежие новости

Загрузка…


3 комментариев на “Обновление JoomGallery до последней версии

  1. это уже не последняя версия, но мне она больше нравится, поэтому пользуюсь ей

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *